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Be able to explain the usefulness of a decision tree
Be able to explain the logic of a decision tree
Be able to explain the differences between a classification tree and a regression tree
Be able to use JMP (analyze > modeling > partition) to construct a classification tree and use
split history and pruning for selecting a best tree
Given a classification tree
1. construct the If-Then prediction model
2. interpret the predictors and their influence using Column Contribution
3. explain the interpretation of G2 and LogWorth
Be able to develop a predictive classification tree.
7. Be able to evaluate the predictive performance of a classification tree using the
misclassification rate, Confusion Matrix and ROC curve
Be able to explain to a manager the insights from a classification tree
Be able to use Trees for problem insights and dimension reduction.
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WHAT IS IT?
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- DeEcisientrees are used for

. They are relatively easy to understand and
explain, particularly to a non-technical audience.

Here are some typical question addressed by decision trees:

« Will a patient be readmitted to the hospital over the next 30
days?

 Willa new movie be a blockbuster? How much will it earn?

 Will a given candidate win an election?

« What is the probability that a flight will be delayed?

 Which variables, out of a large set of potential predictors, are
most important in predicting housing prices?

« What is the risk that an applicant will default on a loan?

Excerpt from Chapter 6: Decision Trees from Building Better Models using JMP (Draft) by Grayson, Gardner and Stephens (SAS Press).
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f Those Product Recommendations Just Don’t Compute

Joe Queenan finds that the algorithms used by Netflix, Amazon and other companies to recommend products are

hopelessly wrong

The Walll Street Journal. | Saturday/Sunday, June 20-21, 2015 | C11
By JOE QUEEMAN

June 18, 2015 11:30
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Defective algorithms are making it increasingly difficult to function in everyday life. With

data in hand about our past purchases and product ratings, many companies now use
these mathematical formulas to determine our supposed likes and dislikes. They use
algorithms to guess what films we’d like to watch, what music we’d like to download, what
cities we'd like to visit and what gifts we'd like to give. The streaming-music service

Spotify is just one gigantic algorithm.

But with shocking frequency, I find that the algorithms used by Netflix, Amazon, Expedia
and other companies to predict my tastes are hopelessly wrong. A case in point: I like to
watch violent movies in which things get blown up. I will watch anything starring Jason
Statham, Bruce Willis, Chow Yun-Fat, the Rock, Arnie or Jet Li, but in a pinch I will also
watch violent films starring Nicolas Cage, Jean-Claude Van Damme, Clive Owen, Jason

Patric and even John Cusack.

Decision Trees | Jim Grayson, PhD The Walll Street Journal. | Saturday/Sunday, June 20-21, 2015 | C11
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= Why then, under “Top Picks for Joseph,” did Netflix suggest that I watch “Grace and

§ Frankie,” a comedy series starring Jane Fonda and Lily Tomlin, about two women whose

i husbands leave them for each other? Why would Netflix suggest that I watch “Hector and
the Search for Happiness,” in which an unfulfilled shrink sets out on a trip around the
world in search of true happiness? What was there about my recent viewing—*“Death
Wish,” “Death Wish 2,” “Killer Mermaid,” “All Hell Broke Loose,” “The Guillotines”—that
would suggest I'd be interested in watching a lighthearted comedy about an unhappy

psychiatrist?

Reviewing my recent viewing habits, I saw only one film out of the last 20 that was not
absurdly violent or scary or twisted or stupid. That was “Shun Li and the Poet,” a sweet
little film about a Chinese bartender in Venice who develops an unusual friendship with a
fisherman from Yugoslavia. But surely the algorithmisti at Netflix should have realized
that watching that film was my wife’s idea, not mine! Moreover, nothing in our collective
viewing patterns would suggest that either my wife or I would ever watch a comedy series

starring Jane Fonda and Lily Tomlin. In my house, we have standards.

Decision Trees | Jim Grayson, PhD The Walll Street Journal. | Saturday/Sunday, June 20-21, 2015 | C11




= ¢ m!"sﬂl_o.n----tre"é"'c:onsists of a set of conditional rules, based on
—simple decision thresholds. The “tree” is essentially a series of
that lead to a classification or
prediction.

As an example, conditional rules that could be used in a credit
risk assessment might look like this:

* Ifincome is > 100,000 and credit rating is > 600 then credit risk is
low, but if credit rating is < 600 then credit risk is high, and

 Ifincome is <=100,000 and credit rating is < 700 then credit risk is
high, but if credit rating is > 700 then credit risk is low.

Excerpt from Chapter 6: Decision Trees from Building Better Models using JMP (Draft) by Grayson, Gardner and Stephens (SAS Press).
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Credit
Applicant

Income > Income
100000 <=100000

Credit Credit Rating Credit Credit
Rating>600 <=600 Rating<=700 Rating>700

Low Risk High Risk High Risk Low Risk

Excerpt from Chapter 6: Decision Trees from Building Better Models using JMP (Draft) by Grayson, Gardner and Stephens (SAS Press).
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" PREDICTING THE LOG SALARY OF =
A BASEBALL PLAYER

e R —

Less Than 4.5
Years?

\% I N

Hits Less Than
117.5?

5.11
6.00 6.74

Chapter 8, Figure 8.1, An Introduction to Statistical Learning, James, et al
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Years

Decision Trees | Jim Grayson, PhD Chapter 8, Figure 8.2, An Introduction to Statistical Learning, James, et al
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HOW IDENTIFIED?




‘| Objective Categorical Response Continuous Response

Exploratory Analysis Classification Trees Regression Trees
(understand data / structure)

Descriptive Analytics Classification Trees Regression Trees
(identify important variables) Logistic Regression Multiple Linear Regression

Predictive Analytics Classification Trees Regression Trees
(predict the future) Logistic Regression Multiple Linear Regression
Neural Networks Neural Networks

Prescriptive Analytics Multiple Linear Regression
(optimal settings)
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predictor variables (X).

ST categorical response variable (Y) with continuous or categorical

Objective

Continuous Classification

or

Categorical

Categorical

Predictive Statistical Model Fit Operational
Accuracy Significance (Error) Understanding
Measure

Mis-
classification
Rate

Column
Contributions;
Confusion
Matrix

RMSE, MAD, ROC
Curve

Entropy
RSquare

All performance in Predictive Analytics is based on the validation set and not the training set
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PLATFORM)?

1. Categorical (Classification Tree) or Continuous
(Regression Tree) Response Variable

2. Can be used for classification or prediction
3. Easy to understand and explain

4. Intuitive

Decision Trees | Jim Grayson, PhD
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HOW TO DO IT

(mechanics of JMP)
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l’pp jmp.com/learn rev 02/2014 ?
Classification Trees (Partition)

Use this data mining technique to predict a categorical (nominal or ordinal) response as a function of potential

predictor variables using recursive partitioning.

ClaSSiﬁcation Trees Example: Auto Raw Data.jmp (Help > Sample Data)
I 1ef Partition - IMP = e

= = Recursive partitioning
From an open table, select Analyze > Modeling > Partition. e e
’ = LClaim(Y/N) i i‘l’, Response |l Claim(Y/N)
4Claim USD
3 || hAge dvtocto ;
Columns and click Y, Response. et =10
. » i :-en er: i-Rating Class
Select explanatory variables and click X, Factor. el &Branch
. . . . . &.0ranch h7one
If desired, enter the Validation Portion (a proportion, as .. ey ol o
< _

shown) or select a validation column and click Validation =4[ Misng value cetegores —

: | validation Porfon | 0] | [ By
(JMP Pro only),
P Pro only, select the tree Method: Decision Tree

Select a nominal or ordinal response variable from Select

Default in JMP, shown), Bootstrap Forest or Boosted Tree.
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jmp.com/learn rev 02/2014

i N )
Jmp
Classification Trees (Partition)

6. Click OK. JMP displays:

A graph, with horizontal lines drawn at the proportion of observations in each response level.
Statistics for the training and validation set(s). Note that results will vary if Validation Portion is used.

A summary of All Rows. Click on the gray triangle next to Candidates to view split statistics for each
column.

7. Click the Split button. The original observations will be split
into two nodes, or leaves (as shown).

Claim{ YN}

Note: Click on the top red triangle and select Display Options >
Show Split Prob to show Rates (proportion of observations)

All Rows

and Probs (predicted probabilities) for the response levels in
each leaf.

[ Sp"[\lt?“ Prune || Go ||C0|orPDims|

RSguare N of Splits  AlCec
Training 0.050 14005 1 346447
Validation 0.047 58095
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-lmp jmp.com/learn rev 02/2014
Classification Trees (Partition)

Interpretation (the response, in this example, is Claim (Y/N)): = All Rows |
-
* There are 1,157 rows in the left leaf, corresponding to AgeClass(Young). Count GA2 LogWorth

The response rate (predicted probability) for Claim(Y/N) = Y is 0.3604. 14005 10243249 11367482

* There are 12,840 rows in the right leaf, corresponding to AgeClass(Elder). Level Rate Prob
I 08806 08806

The response rate (predicted probability) for Claim(Y/N) =Y is 0.097. Y 01194 01194

I
: . . , : | |
8. Click Split to make an additional split. Click Prune to remove a S hgeClass(Young) |[EAgeCiass(Elden

split. If a validation portion or validation column is used, click Count v Count e

Go to perform automatic splitting. 1165  1524.206 12840 B202.1643
Lewvel Rate Prob (| Level Rate Prob

M 06386 08384 || M 089026 09026
Y 03614 03612 ||Y 00974 0.0974
Candidates Candidates
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.Imp jmp.com/learn rev 02/2014
Classification Trees (Partition)

Notes:

For additional options, such as Column Contributions, ROC and Lift Curves, click the top red triangle. Other
options, such as Save Prediction Formula and Make SAS DATA Step, are available from the top red triangle >
Save Columns. For split options for a particular node, click on the red triangle for that node.

For more information on fitting and evaluating classification trees, including Validation, Bootstrap Forest and
Boosted Trees, search for “partition trees” in the JMP Help or in the Specialized Models book (under Help >
Books).
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RIDING MOWER EXAMPLE
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RIDING MOWERS

~Ariding- mower manufacturer would like to find a way of
. . ope . . . . . . Income Lot_Size Ownership
classifying families in a city into those likely to purchase a riding 60 184 owner

85.5 16.8 owner

mower and those not likely to buy one. A pilot random sample 6as 216 owner

. . . 61.5 208 owner
is undertaken of 12 owners and 12 non-owners in the city. - e

110.1 19.2 owner

108 17.6 owner

| *Income 4 v Lot Size 4 = Ownership 82.8 224 owner

69 20 owner

120 244 93 20.8 owner

110 1 51 22 owner

221 81 20 owner

75 non-owner

owner

[source: Data Mining for Business Intelligence, 2e by Shmueli, Patel and Bruce, Wiley Publishing]

100+

90 NonN-oOwWner

80 64,8 non-owner

nNoON-oOwWner

10 84 non-owner

6[] 1 non-owner

59.4 non-owner
50 non-owner 66 non-owner

40 non-owner

30+

33 non-owner

51 non-owner

Decision Trees | Jim Grayson, PhD 63 non-owner




PLATFORM

| Analyze | Graph Tools Add-Ins  View Window Help
== Distribution H | B
Y. Fit¥byX ‘

== Matched Pairs

Tabulate

=u  Fit Model

Modeling d2E Partition cursively partition the data to
predict a response, Classification and
regression trees,

Multivariate Methods T

Quality and Process Model Comparison

Reliability and Survival v Monlinear

Gaussian Process
Consumer Research

AV OWner Tirme Series
196 non-owner
208 non-owner Screening
17.2 non-owner

Response Screening
204 non-owner
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£E Partition - JMP Pro | ]S

Recursive partitioning

Select Columns Cast Selected Columns into Roles Action

= 3 Columns ¥, Response | ik Ownership | 0K |
dlncome
ﬂLu:ut_SizE
i Cwnership

| Cancel |

| X, Factor | 4l Income
il Lot_Size Remuove

| Informative Missing

¥ | Ordinal Restricts Order — Recall
elgnt —

Method Decision Tree ] Help

Validation Portion Freq

WValidation

By
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HOW DOES IT WORK?
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HOW DOES IT WORK?

A top down, greedy algorithm known as a
Greedy because the algorithm seeks for the immediate “best” spllt
not the long term down the tree further best split.

-> the greatest reduction in RSS
(residual sum of squares)

-> the smallest measure of node
purity, meaning observations are predominantly from a single class

Decision Trees | Jim Grayson, PhD




= Partition - JMP Pro

Recursive partitioning

Select Columns Cast Selectedg

*! 3 Columns ¥, Response | th Ownership

AIHCDI‘TIE

Action
L ok |

| Cancel |

ALot_Size

. Ownership |  Factor | 4lIncome

Al Lot_Size

| Informative Missing

| Ordinal Restricts Order |
Method |Deci5ior1 Tree Vl

Validation Portion ] | Freg |

| validatien |

Weight |

Data source: “RidingMowers” from Data Mining for Business
Intelligence, 2e, Shmueli, et al (Wiley)
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| Remove |

| Recall |

| Help |

|

~|Partition for Ownership
1.00

Split || Prune ||CDIDrF‘Dint5

*All Rows
[
Count G"2
24 33.271085

Candidates

RSquare
0.000

All Rows

MNumber
N of 5plits
24 0

non-owner




Gini index = most pure and is calculated
as 2p,p, so that as either of the class
probabilities is closer to zero the index is
minimized; it is maximized if p; = p,

Split || Prune ||C|:|I|:|rF'|:uir1t5.| Mumber
R5quare N of 5plits
0.000 24 0

* All Rows Information Gain or gain(split) =
O info(prior to split) — info(after split)
Count G"2
24 33.271065 Candidate G2 = Likelihood ratio chi-
A Candidates square for the best gplit. Shown if the
response is categorical.

Candidate
[—

Term i LogWorth = The LogWorth statistic,
__Income : defined as -log10(p-value). The optimal
Lot_Size 5.51146""]"15 1e62790227 20 split is the one that

Decision Trees | Jim Grayson, PhD




Di5p|a)h[]ptinn5

Pt Best
Prune Worst

PMinimum Size Split

Lock Columns

Small Tree View

Leaf Report

Column Contributions

Decision Trees | Jim Grayson, PhD

Show Points

Show Tree

Show Graph

Show Spht Bar

Show 5Split Stats
Show S5plit Prob

Show Splt Count
Show Split Candidates
Sort Split Candidates




p 1-p GA2
0.5 0.5 27.73 =2%(A3%(-LN(C3)) + B3*(-LN(D3)))
0.667 0.333 191
0.333 0.667 19.1
0.091 0.909 6.702

LogWorth
p-value LogWorth
0.1  2.30259  =-LN(C11)
0.05  2.99573
0.01 4.60517
0.005  5.29832
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| '~/ Partition for Ownership

1.00 +
| + +
+ n n
‘ * First Split
== 075 4 " owner
N +
§ 050 4
g
O .+-‘
0.25 non-owner
.+_
0.00
| Income>=85.5 Income<85.5
All Rows
: > All Rows
Split | Prune ||ColorPoints Number [ ——
- RSquare N of Splits Count 672 LogWorth
9 P 24 33271065  1.408425
0.222 24 1

T Income:>=83.5 T Income<85.5
I
Count G"2 Count Gn2
5 0 19 25.00818
4 Candidates 4 Candidates
Candidate Candidate
. . Term G2 LogWorth Cut Point Term G2 LogWorth Cut Point
Second Split Candidates : 2 R
Lot_Size 0 a. Lot_Size 9308823071 * 1776474652 20
Constrained by minimurm size
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* Partition for Ownership
1.00

Income=>=85.5

Split || Prune ||C|:|I|:|rF'|:uir1t5.

Decision Trees | Jim Grayson, PhD

Lot_Size==20 Lot_Size<20

RSquare
0.497

Income<85.5

WS

Mumber
N of Splits
24 2

non-owner




e

*Income<85.5

| |

Count G2 LogWorth
19 2500818 1.7764747

" Lot_Size==20 *Lot_Size<20
] I |-
Count G2 Count G2
8 89973623 11 6.7019941

4 Candidates < Candidates

Candidate Candidate
Term G"2 LogWorth Cut Point Term G"2 LogWorth Cut Point
Income 0 0. Income 1.295259635 < 01110025729 &0
Lot_Size 0 0. Lot_Size 1.295259635 > 01154386072 176

Constrained by minimurn size
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s ———

/

~/Partition for Dw_rzlership

1.00
+ +
0.75
+ +
s ot
5050 +
5
+
0.25 non-owner
*'Lot_Size<20
I I
+ Count G*2 LogWorth
0.00 Lot_Size>=17.6 Lot_Size<17.6 11 67019941  0.1154386
Lot _Size==20 Lot Size<20 |
Incomes= =855 Income<85.5 | |
Al Rows *Lot_Size>=17.6 *Lot_Size<17.6
I ||| |
5 5 Count G2 Count G2
Split || Frune ||C|:|I|:|r Points Muml:!er 6 54067345 < 0
RSquare N of Splits - -
0514 24 F I’ Candidates I’ Candidates

Decision Trees | Jim Grayson, PhD



Decision Trees | Jim Grayson, PhD 38

HOW TO INTERPRET THE RESULTS




P

qr: atlonRate and Confusion Matrix

Display Options Fit Details
Split Best

Prune Waorst

Measure Training Definition

Minimum Size Split Entropy RSquare 0.5145 1-Loglike(model)/Loglike(0)

Lock Columns Generalized RSquare 0.6799 (1-(L(0)/L(model))"(2/n))/(1-L(0)*(2/n))
Small Tree View Mean -Log p 0.3365 > -Log(p[j)/n

Leaf Report RMSE 0.3171 ¥ X(y[jl-p[1)*/n

Column Contributions Mean Abs Dev 0.2391 5 Iylil-plil|/n

Split History Fisc|assi?ication Rate  0.1250 > (p[jlzpMax)/n I

K Fold Crossvalidation N
ROC Curve
Lift Curve

@w Fit Details >

Save Columns 9 Actual Predicted
Specify Profit Matrix

24 n

Confusion Matrix

Training  non-owner owner
non-owner 2

Color Points

Script
owner 11
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Display Options
Split Best

Prune Worst

Minimum Size Split
Lock Columns
Small Tree View

Leaf Report

Column Contributions
Split History

K Fold Crocsyvalidation

Show Fit Details

Save Columns
Specify Profit Matrix
Color Points

Script

Decision Trees | Jim Grayson, PhD
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ROC CURVES

Receiver Operating Characteristic
1.00

0.90

Sensitivity
o
L
o

0.40

0.30

0.20

0.10

0.00+
0.00 0.10 0.20 0.30 0.40 0.50 0.60 0.70 0.80 0.90 1.00
1-Specificity

Ownership  Area
" non-owner (0.9271
== owner 0.9271




P

e

Split Best

Split History
1.00

Prune Worst

Minimum Size Split

Lock Columns
0.75

Small Tree View

Leaf Report
0.50

Column Contributions

K Fold Crossvalidation

0.25

ROC Curve

Lift Curve

0 2 4 6 8 10
Number of Splits

Show Fit Details

Save Columns k
Specify Profit Matrix
Color Points

Script
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ST~ NN CONTRIBUTION

Prune Worst

Minimum Size Split

Lock Columns

Small Tree View

Column Contributions

Split History

Column Contributions

Number

K Fold Crossvalidation Te rm Of SplitS GAZ POI‘tiOI‘I
Eicc':m” Lot_Size 2 10.6040827 0.5620

Income 1 8.26288514 0.4380

Show Fit Details

Save Columns
Specify Profit Matrix
Color Points

Script

Decision Trees | Jim Grayson, PhD
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HOW TO USE IT




= Partition for Ownershin
Display Options 3

Split Best

Prune Worst + +
Minimurn Size Split

Lock Columns

Small Tree View

Leaf Report

v  Column Contributions

v Split History
K. Fold Crossvalidation
v ROC Curve

¥ Lift Curve Lot_Size»=

v Show Fit Details Lot_Size==20

Save Columns 2 Save Residuals

Prob{Ownership==non- Most Likely
owner) Prob{Ownership==owner) Ownership

0.7926934524 02073065476 non-owner
00833333333 09166006667 owner
0.27916006667 07208333333 owner

Specity ProriT et Save Predicteds

Color Points Save Leaf Mumbers

Script ] Save Leaf Labels
(Save Prediction Formula g
Save Leaf Mumber Formula

Decision Trees | Jim Grayson, PhD




Prob(Ownership==non-owner) m——

Income == 85.5 = 0.08333333333333

. Lot Size == 20 = 0.27916666666667
If

else = If Lot Size ==17.6 = 0.79269345238095
glse =If

else = 0.92480002777778

Prob{Ownership==owner)

Income == 85.5 = 0.91666666666667

Lot Size == 20 = 0.72083333333333

Lot Size ==17.6 = 0.20730654761905
glse =If

else = 0.07519097222222

Prob(Ownership==non-owner) = "non-owner"

Prob{Ownership==owner) = "owner"

FIF
Decision Trees | Jim Grayson, PhD EIEE =
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HOW TO UNDERSTAND MANAGEMENT
IMPLICATIONS




7- - - - e T Tree Stru Ctu re
Relative Influence Eaa |

Column Contributions All Rows
Income

Number
Term  of Splits GN2
Lot Size 2 10.6040827
Income 1 8.26288514

Prediction and Classification

Prob{Ownership==owner) Jim P e RS LY (=T T= 1010

Income == 85.5 = 0.91666666666667

Lot Size == 20 = 0.72083333333333

[ot Size ==17.6 = 0.20730654761905
else =1If

else = 0.07519097222222
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Isclassification Cell Analysis

Confusion Matrix

Actual Predicted

Training  non-owner owner
non-owner 2

owner 11
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PREDICTIVE MODELING EXAMPLE

Using a validation column




Default Credit Card Default Dara

References: Games, G., Witten, D., Hastie, T., and Tibshirani, R. (2013) An Introduction to Statistical Learning with applications in R,
www.StatLearning.com, Springer-Verlag, New York

Description
A simulated data set containing information on ten thousand customers. The aim here is to predict
which customers will default on their credit card debt.

Usage

Default

Format

A data frame with 10000 observations on the following 4 variables.

default A factor with levels No and Yes indicating whether the customer defaulted on their debt

student A factor with levels No and Yes indicating whether the customer is a student

balance The average balance that the customer has remaining on their credit card after making
their monthly payment

income Income of customer

Decision Trees | Jim Grayson, PhD




Create a validation

variable associate
it with the
validation role In
the dialog box

Decision Trees | Jim Grayson, PhD

Cast Selected Columns into Roles

|1'rrr F{es.pujns_el i default

| X, Factor | ik student
4l balance

4l income

| Weight

| Freg

Validation | | Validation >




Partition for default
1.00

~ Because we have
we
either select “Go”
for automatic
selection or

repeatedly select
“Split” and then
“prune” by Training 0.000 7000 0

Number
RSquare N of Splits

Validation . 3000

examining split
history —

Count GMr2
7000 20437811
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| =/ Partition for default

The automatic
“pruning” process

ancy
student(¥| student(Mo) Etufstud F SplitHistory
es) de|enti]
balance<959.1592134 balance>=959.1592134 palance
<18?1:‘% |
balance<1473.034561 balance>
=1473.03

All Rows

Split || Prune H Go ]lCu:qu:urF'u:uints Number
RSquare N of Splits 10
Training 0451 7000 7 Nimbes of Spi
Validation 0466 3000
Validation Data in Red
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__Looking at the entire tree we can see that

“balance” is the most significant column contributor

= All Rows
l
Count G*2 LogWorth

7000 2043.7811 30036702

~ balance<1473.034561

Count G*2 LogWorth
6272 54386104 0993411

~ balance <959.1592134 ~ balance>=959.1592134
I

Count G2 Count G*2 LogWorth

~ balance>=1473.034561

Count

G*2 LogWorth
728 §29.56404 45241556

~ balance<1871.938387

Count

G"2 LogWorth

4227 34618721 2050 425.09246 21110875 590 527.34862 2.7260876
P’ Candidates | | | | | |
T student(Yes) *'student(No) " student(Yes) T student(No)
Column Contributions Count G~2 LogWorth
350 353.03649 1779332
Mumber |
Term of 5plits G"2 Portion [ |
balance 5 005.287953 | 00818 ~balance <1750.25315 || = balance>=1750.25315
student 2 16.7561979 ] 0.0182 Count GA2 Count GA2
income ] a : : 0.0000 290 25367783 60 81.503192
I’/ Candidates I’ Candidates
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~ balance>=1871.938387

Count G*2 LogWorth
138 17832098 0.9261262

*'balance<2023.733603 || "~ balance>=2023.733603

Count G"2
70 75.256218

I’ Candidates

Counit Gn2
68 94032587

I’ Candidates




___ Fit Details

e —

| Measure Training | Validation |Definition
— Entropy RSquare 0.4511 0.4659 1 -Loglike(model)/Loglike(0)

Generalized R5quare 0.4574 0.5023 J1-(LO)/Limodel))*(2/n))/(1-L{O)"(2/n]))
PMean -Log p 0.0801 -Leg(p[j])/n

RMSE 0.1467 01449 K S(y[jl-p[1)*/n

Mean Abs Dev 0.0431 lv[j1-el]l/n

Misclassification Rate 0.0273 (p[)]#pMax)/n

M 7000 n

4 Confusion Matrix
Actual Predicted | Actual Predicted
Training Yes No Validation Yes No
Ves a0 143 Yes 39 Bl
Mo 48 6719 Mo 21 2879
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e

Receiver Operating Characteristic on Validation Data
1.00

0.90

0.80

0.70

0.60

0.50

Sensitivity

0.40

0.30 /

0.20 /

0.10 //
0.00
0.00 0.10 0.20 0.30 0.40 0.50 0.60 0.70 0.80 0.90 1.00
1-Specificity
default Area
— Yes 0.9423
= No 0.9423
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Prob{default==Yes)

balance < 9591592134 = 0.00048086454533

student == "Yes" = 0.01077821297826
balance < 1473.034561 = If

student =="No" = 0.02756677021332
else = 0.02146791368841

student =="Yes" = 0.10815964409653

balance < 1750.25315 = 0.15835076860238
else = 0.41114874857855

balance < 1871.938387 = If| student == "No” = [f

else = 0.16422269591591

balance < 2023.733603 = 0.52340348070535
else = 0.76218084744605
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If we use the Model Comparison feature we can
access the profiler and influential variables

First: Save Prediction

Formula: Save Columns

> Save Prediction
Formula

Decision Trees | Jim Grayson, PhD

4 = Partition for default
Display Options

Split Best

Prune Worst

Minimum Size Split

Lock Coelumns

Small Tree View
Leaf Report

Column Contributions

Split History

K Fold Crossvalidation
ROC Curve

Lift Curve

Show Fit Details

|
13.034561
.
12 LogWorth
104 19.338513

=1

Ubalance:=959.1592134

Count G2 LogWorth
2050 42509246 21110975

I
Save Celumns ) Save Residuals
Soecify Profit Iato Save Predicteds

Color Points

Script

Save Leaf Mumbers

Save Leaf Labels

\_@Prediction Formula
g leaf Mumber Formula %

Save Leaf Label Formula

Make SAS DATA Step



¥« FitVbyX

Tabulate

Fit Model

Matched Pairs

View Window Help
H | £ 3

Validation
07 Training
47 Training
85 Training
04 Validation

0.0004808645
0.0004308645
0.0275667702
0.0004808645

Prob(default
==MNo)
09995191355
09995191355
09724332298
09985191355

9985191355

Most Likely
default
Mo
Mo
Mo
Mo
Mo

Mn:u:leling)

Multivariate Methods

32 Partition

0995191355 Mo

0005101255 Kln
Find predictor columns for the same
target response and compare how
well they fit

OO95TUTE5S Mo

0995191355 Mo

1989221787 Mo

0995191355 Mo

0995191355 Mo

0724332298 Mo

0995191355 Mo

0.0004808645 09995191355 No

Quality and Process Dy Model Comparison

Reliability and Survival % MNonlinear

Consumer Research 3 e
Yes 1220583753
Mo 237045114
Mo 606.7423433
Mo 1112.968401
Mo 286.2325601

Mo ]

153268.36) by Time Series
28251.69

44994.55

2381017 .
4504241 =
50265.31235 Validation

Screening

Response Screening
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o Comparing predictors to see which performs better.

Select Columns Cast Selected Columns into Roles Action

'8 Columns |, Predictors | oK |
thdefault

thstudent
dlbzlance
dlincome
III - —
dlprob(default==Yes) | Recall |
ﬁF‘rnb(dEfauIt::ND] |
Mot Likely default

| Cancel |

| Remove |

Help |

If you choose no Predictor columns, it will find an
analyze all predictors.
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e

~ Model Comparison Validation=Training

snmo—
e~/ Model Comparison Validation=Validation

S | Predictors

4 Measures of Fit for default

Entropy Generalized Mean Misclassification
Creator .2.4.6.8B RSquare RSquare Mean-Logp RMSE Abs Dev Rate M
Partition | . 0.45659 0.5023 0.0781 0.1449 0.0405 00275 3000

4 = Profiler Validation=Validation

4= Prediction Profiler

default

Mo

balance student
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I
Prediction Profiler

Mo [.972 : /

1

default

\:iL"!rI\_:L"lEL"lEL"! ZCI E
- T r— o~ =
mMEEAERE

= — ("]
1250 Mo
paance AN [0

4= Variable Importance: Independent Uniform Inputs

4 Summary Report
Column Main Effect Total Effect .2 4 6 8
balance 0.994 0.999 |
student 0.004 0.01|
< Marginal Model Plots
1.00
0.75 —
E 0.50 InJ
0.25 ji _
0.00 Jr
= L"! ll‘_-j L"! E L"! Ii.::ll L"! o E
mEednESo = =
m 5 3 =
balance student
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DECISION TREES: REGRESSION TREE




s jmp.com/learn rev 02/2014

Regression Trees (Partition)

Use this data mining technique to predict a numeric (continuous) response as a function of potential predictor

variables using recursive partitioning.

Regre.SSion Trees Example: Diamonds Data.jmp (Help > Sample Data)

| 28 Partition - IMP o= ()
Recursive partitioning
From an open table, select Analyze > Modeling > Partition. Sefect Golumns Cast Sebected Columns into Rokes Action
- ) ™ dCarat Weight ¥, Response| |4l Price | ok
Select a continuous response variable from Select Columns i Cobor legponse dPrce A
- Clarity X Factor | . Uzlr:rt eight | Cancel
and click Y, Response. 4Depth & Clarity
. . ave 4 Depth |Remcve
3. Select explanatory variables and click X, Factor. o 4Table T
) . . . ) AP : ik Cut —
If desired, enter the Validation Portion (a proportion, as e Report |_Help
. . . . . Missing value categories Weight |
shown) or select a validation column and click Validation Vaiigation Porton [ 03] — =
. _ Frea |
(JMP Pro only). By |
5. InJMP Pro only, select the tree Method: Decision Tree )

(Default in JMP, shown), Bootstrap Forest or Boosted Tree.
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jmp.com/learn rev 02/2014

Regression Trees (Partition)

6. Click OK. JMP displays:

A graph with lines drawn at the overall mean response value.
e Statistics for the training and validation set(s). Note that results will vary if Validation Portion is used.
* A summary of All Rows. Click on the gray triangle next to Candidates to view split statistics for each

column.
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jmp.com/learn rev 02/2014

Regression Trees (Partition)

‘|-|‘ Diamends Data - Partition of Price - JMP

7. Click the Split button. The original observations will be split

4 =|Partition for Price

into two nodes, or leaves (as shown). S

$7,000.00J8
$5.000 00 .

Price

Note: In the graph, horizontal lines are drawn at the mean
$3,000.00 3

response within each leaf and vertical lines depict the leaf’s 103000

Carat Weight<0.95 | Carat Weight==0.95
All Rows

relative size.

[ it rune 30 MNumber
. . : Sﬁb H 8 & | RSquare RMSE N of Splits  AlCe
Note: In the graph, horizontal lines are drawn at the mean L M L } SE03

Validation 0.609 1526.2262 806

response within each leaf and vertical lines depict the leaf’s
relative size.
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jmp.com/learn rev 02/2014

Regression Trees (Partition)

| = Partition for Price

Note: In the graph, horizontal lines are drawn at the mean

response within each leaf and vertical lines depict the leaf’s

relative size.

$3.000.003
$1,000.00

Interpretation (the response, in this example, is Diamond Price in $):

Carat Weight=0.95 | Carat Weight==0.95
All Rows

¢ In the left leaf there are 1,080 rows with Carat Weight < 0.95. The
mean cost of these diamonds is $2,249.93.

* In the right leaf there are 825 rows with Carat Weight >=0.95. The
mean cost of these diamonds is $6,110.16.

~All Rows
Caount 1884 LogWorth Difference
Mean J917.0605 896.38481 38255
Std Dey 2409 1107

T'Carat Weight<0.95|[ ™ Carat Weight>=0.956
Coount 1055 || Count a219
Mean  2254.05629 |[Mean  6079.5665
Std Dev 1151.7525 || Std Dev 18308113

Candidates Candidates

8. Click Split to make an additional split. Click Prune to
remove a split. If a validation portion or validation column

are used, click Go to perform automatic splitting.
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e JT TN jmp.com/learn rev 02/2014

Regression Trees (Partition)

Notes:

For additional options, such as Leaf Report, Small Tree View, Column Contributions, click the top red triangle.
Other options, such as Save Prediction formula and Make SAS™ DATA Step, are available from the top red
triangle > Save Columns. For split options for a particular node, click on the red triangle for that node.

For more information on fitting and evaluating regression trees, including Validation, Bootstrap Forest and
Boosted Trees, search for “partition trees” in the JMP Help or in the Specialized Models book (under Help >
Books).
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2lE Partition - JMP Pro - - 5 e

= |Recursive partiticning
e Select Columns Cast Selected Celumns inte Roles
= | ™' 7 Columns |¥, Response| 4l Price
dprice
.ﬂLi*.fing Area
dlBedrooms
ﬁEI.athrn:n:ums |m| A Living Area .
AFireplaces — | dBedrooms =
‘f!—\ge 4l Bathrooms
L 4l Fireplaces =
| Informative Missing | Weight |
| Ordinal Restricts Order | Freq |
Method | Decision Tree v | [ Validation | [Validation
Validation Porticn | —/—————
. By |
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600000
550000
500000
450000
400000
350000
300000
250000
200000
150000
100000 V&S
50000 »e  *°°
0

Living Area<1326 Living Area>=1326

Living Area<1720 Living Living Area<2/72 |Living
Area>=1/20 Area>=
Living Area<2058 Living Area>=2058

All Rows
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Number
oo —————— RSquare RMSE N of Splits AICc
Training 0.555 5163356 846 4 207744
Validation 0.554 50821.003 211

All Rows
Count 846 LogWorth Difference
Mean 168429 161.59954 105767
Std Dev 77410816

Count
Mean
Std Dev

Living Area<2058

583 LogWorth Difference
135548.75 38.079288 502544
49382.203

Living Area>=2058
Count 263
Mean 24131562
Std Dev 78557.521

LogWorth Difference
25.834574 90099.1

Living Area<1720

Count 438
Mean  123049.82
Std Dev 43115.128

Living Area>=1720
Count 145
Mean  173304.17
Std Dev  48001.854

LogWorth Difference
9.3902587 24810.2

Living Area<2772

Living Area>=2772

Count 187 || Count 76
Mean 21527939 || Mean 30537846
Std Dev 58707.051 || Std Dev  84628.75

Living Area<1326
Count 200
Mean 109568.5
Std Dev 43168114
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Living Area>=1326
Count 238
Mean 134378.65
Std Dev 39757552




Split History
1.00

0.75

0.50

0.25

0.00
10

Number of Splits

Validation Data in Red
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’ Actual by Predicted Plot

Training Set

» 600000
— 550000
500000
450000
400000
350000
300000
250000
200000
150000
100000
50000

0

Actual

0 100000 250000 400000 550000
Predicted

Validation Set 600000
550000
500000
450000
400000
350000
300000
250000
200000
150000
100000
50000

0

Actual

0 100000 250000 400000 550000
Predicted
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Column Contributions

Number
Term of Splits SS

Living Area 4 2.8082e+12
Bedrooms 0

Bathrooms

0
Fireplaces 0
Age 0
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Living Areg < 2058 = [f

Living Area < 1326 = 109568.5
Living Area <1720 = [f

else = 134378.651260504
else =173304.165517241

Living Area < 2772 = 215279.385026738

else = 305378.460526316
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